• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [5287] Internal error with battle and autobattle

Amarthano

Guest
In a crystal province 8 hexes away from my city I just experienced two fights which end up in an internal error if you chose to auto-fight them:

elvenar06.jpg
Here are the two error encounters, the other 6 worked fine in auto-fight.

Northern encounter:
elvenar07.jpg

Southern Encounter (attack consisted of treants only too):
elvenar08.png


edit:

1) Fighting these two encounters normally (non-auto) opens the battlefield screen, but then gives the internal error at the start of combat round 2. So the thread title is not really correct.

2) Error seems to be related to composition of troops. Replacing 1 treant squad by 1 golem squad lets you complete the encounter(s) without any errors (tested northern fight manually, southern fight Auto).
 
Last edited by a moderator:

Darkstar

Ex-Team Member
Thank you for reporting this to us, Amarthano. We will investigate the issue using the information you have provided.
 

lenore

Well-Known Member
Also for me in a crystal province 8 hexes away from my city.
I tried to battle with treant and archer and with treant and golem... but there is always internal error.
Internal error is after I attacked the orcs?
I try again....

Ok... these are my tests.
my squad: 3 archer, 2 treant,
second round, last of my moves: internal error
my squad: 5 treant
first round, last of my moves: internal error
my squad: 3 golem, 2 treant
first round, last of my moves: internal error
 
Last edited:

DeletedUser967

Guest

Amarthano

Guest
Thank you, Darkstar, for renaming the thread.

Meanwhile I believe this problem might be a pathing issue rather than connected with the army composition. Sorry for not having any detailed information this time, but here is what happened:

* Fighting an encounter in a (non-crystal) province I had the internal error happen again (I used treants and golems). After resuming the fight (the "unfinished business" & "continue combat" - option is very convenient btw.!) I could reproduce the error by repeating my exact move, but once I moved my unit (whose turn it was immediately before the crash) somewhere else, the fight continued without any problems.

* In another fight the enemy managed to surround one of its (own) wardog units, so that it could not reach any of my stacks during its next turn (it would have been able to, but all possible paths were blocked by its allies). In this situation there was nothing I could do (neither changing troop types nor moving elsewhere with my own units) to prevent the internal error.
 

Darkstar

Ex-Team Member
Apologies for the late reply. It does appear that this is mostly a "pathing" issue, but that in itself is also related to army composition. The issue is unfortunately hard to constantly reproduce, but it does happen. The cause behind it could be both the battle terrain and the unit squads themselves. The combination of the two, especially when using AI (autobattle for example) can lead to a "stalemate" and nothing happening, so the game gives you an error.

So, partial reproduction steps would include:
1. Enter a distance 7 or 8 province;
2. Locate an encounter whose terrain seems to "block" the straightforward path of both player and enemies;
3. Select units with low movement and non-ranged attacks;
4. Try autobattling with that formation.

If anyone does come across a similar case, can you take a screenshot at the start of manual combat in that encounter using the same units you got the error with on autobattle? Observing the terrain and units involved could help locate the exact issue (you do not have to complete or do the battle, you can surrender once you've obtained the screenshot). Please and thank you!
 

methusu

Guest
Today I had the internal error in this situation:

Bildschirmfoto vom 2015-05-11 00:07:18.png

My last action was attacking the orcs with my sworddancers. Like Amarthano I could finish the fight with moving my sworddancers to the hex left instead of to their shown position, also attacking (and killing) the orcs. Thereafter the war dogs moved towards my sworddancers, they did NOT attack my treants!

Because the dogs already showed a strange behaviour in a previous round of the example fight, it seems to me, that war dogs are dominantly involved in this bug.
 

methusu

Guest
Might be an additional change, that was not announced, but may save you from some losses, when you get an internal error and there is no way to finish the battle.

But if this intended, there might be a way to cheat by relogging, if a battle doesn't go the way you want it.

Edit: Hmm, I missed to look at your posting date, ulQuiorra, it was before today's update. For me every fight I continued with older versions worked the way it should.
 

Wolphy

Well-Known Member
I have experienced this issue several times after latest update, there are encounters that I am not able to finish because of internal error. Whether I continue combat or retreat and start again, error occures at the same point. Examples are shown on screenshots, after moving those particular units, error occured and game reloaded.
I have also noticed that dogs, even if they reach my troops in the first move, not always attack them but it seems to be another bug.
 

Attachments

Amira

Guest
the same problem with one sector in the province with crystal - if I fight manuell - situation for the error:

and situation after one move:
 

Juni

Well-Known Member
so, since I have that very same message, what is the advice meant to be in that error?

especially "Please try it again later". when is later? is one hour waiting sufficient? because I have some resources to harvest, and would like to continue.
 

Darkstar

Ex-Team Member
The error message is a standard one. You can complete the battle even seconds afterward, it's caused due to weird blocking movement of units. So as other players above have mentioned trying a different approach/movement should work.
 

LordB

Well-Known Member
Just encountered the same issue. In three crystal encounters.
In the first it worked after I ended the turn for the archer squad, that before alsways got an internal error attacking orcs (tried to attack two different squads = always error).
In the second encounter i first tried 4 treants 1 archer, but no matter what squad I attacked with the archers, or where i moved it and end turn always internal error. Then I tried 5 squads treants -> internal error, only 4 squads treants and nothing else -> internal error, only 3 squads treants -> it finally worked, but i took unnecessary losses due to fighting with only 3 squads...
Third encounter -> internal error and I quit fighting, cuz I'm sick of trying to get around the error...:mad:
 

Darkstar

Ex-Team Member
Please let us know if you're still experiencing this issue after the 0.17 update, as the update itself includes a fix for errors in certain encounters. :)
 

Marindor

Community Manager
Elvenar Team
Since there has been no recent reports of this (since the last update), we will now move this thread to the "Fixed" section but we will leave it open for further replies, should anyone still encounters these issues!