• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [44550] RR upgrades into next chapter without researching Advanced Scouts is possible


Active Member
Game version: v1.178-beta.11-(30e9597) - html5 (2023-06-16 07:55)
Game world: Beta
Browser/IOS/Android + version: Firefox 114.0.1 (64-bit)
Operating System or Mobile Device: Linux (Manjaro)
Screen resolution: 1920x1080
Account name: Ergolas77
Humans or Elves: Elves

Reproducibility: 5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)

Quest title: (if applicable)

Current situation:
I am at the end of chapter 14 Constructs but I have not yet researched Advanced Scouts to enter chapter 15. I've been sitting here for a while (a couple of months).

This morning I noticed I am able to upgrade ch14 buildings into chapter 15 even though I shouldn't be able to until I complete research for Advanced Scouts in chapter 15 (I successfully upgraded Echoes of the Forgotten and Triumph of the Tides).

Elvenstats says I'm in chapter 15.

I now have the option to decline the chapter 14 quests I did not complete.

I am UNABLE to upgrade Magic Workshops and Magic Residences to chapter 15. I get the RESEARCH block on that. So that's right.

Expected situation:

I should not be unable to upgrade buildings and decline the ch14 research until I complete the research for advanced scouts in ch15.

Reproduction Steps
1. Complete research for ch14
2. Add 85kp to the research for Advanced Scouts ch15 but do not complete it
3. Attempt to UPGRADE a chapter14 building to chapter 15 (this is allowed and shouldn't be)
4. Click on quest line from ch14 that is not completed, the option to DECLINE is there (this should not be the case)
5. Click on ch14 Magic Workshop / Magic Residence and attempt to upgrade (this is NOT allowed as expected)

Other observations

1. In the map view my city looks like chapter 15
2. Elvenstats says I'm in chapter 15
3. In spire, I won a chapter 15 magic residence AND a chapter 15 magic workshop

Add more steps if needed. Include only ONE action for each step!

Screenshots of the bug:




  • 1687011454327.png
    202 KB · Views: 73
  • 1687011483336.png
    205.8 KB · Views: 68
Last edited:


Well-Known Member
Same situation here (other chapter). Scouts are full with KP but not learned yet.
I can't upgrade using blueprints, but can upgrade with Restorations.
Also, prizes (buildings) in the Season are of the next chapter.

P.S. Interesting thing with blueprints: Chapter is shown as "requirements met" (not red), but Research is needed according to the button. Probably, if I would have any restoration, situation would be different.


Well-Known Member
Magical buildings are specifically listed in techs and not bound to chapters themselves (remember those times when they become available after researching normal residences/WS in some chapters?).
My guess is that chapter is now switched when you open the locked chest and not when you research first tech (as my migrated city with chest locked shows chapter 4 in season prizes).
Last edited:


Well-Known Member
i did not want to change of chapter on my level 3 coty , but far more not upgrade my end of tech chapter 15 !!! this last change is worse and no communication about it


Well-Known Member
need to be investigated BEFORE chapter migration in live ... to avoid introducing impact on big cities that could change of chapter due to this bug


Well-Known Member
The Spire also treats me as the one in the next chapter (now I have orcs in negotiation).
Still no possibility to upgrade premium buildings till the 1st technology is learned (have done it - now it works fine). Premium buildings are the only ones that are left in the old chapter-changing way, all the rest is follows the new way (probably due to different chapter-changing mechanics as Karvest explained).

Hope, we'll get clarification on the matter soon (is this intended or not).


Well-Known Member
my guess

previous rule : change of chapter after validation of first technology (including magical building increase capability)

new rule due to bad implementation of chapter 5 migration, instead of automatic validation of first techno , change of the rule , chapter 5 validated when chest open , but rule for magical building increase after first techno validation remains ( and it look like that this new rule applied on all chapter )

that have effect on every city where player decided to stop evolving , and will lead new resources needed in dungeon or tournament
==> PLEASE don't apply in production

Deadeye Jerry

Community Manager
Elvenar Team
Shereane already moved to the next chapter properly, if they are still experiencing the issue now for the next chapter, please notify me or anyone in the team.


Active Member
I have sent a message asking if anyone else in my fellowship is experiencing this issue. Will let you know who responds "yes".

I think the fighting might be more difficult now, which would be a big negative for other players who are staying put for a while like I am. I will remain where I am until this ticket is resolved.

Let me know if I can assist further in resolving / reproducing this.


Active Member
I just checked and it appears as though my city is in chapter 14 again and the issue looks to have been recently resolved @Deadeye Jerry .

I am no longer able to upgrade a building with RR's to chapter 15, although I did do that earlier this morning on a mana plant for the event.

Prizes in the season rewards are chapter 14 versions again.

v1.178-beta.17-(79aa614) - html5 (2023-06-26 08:56)