• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Not a Bug teleport requires a builder

maxiqbert

Well-Known Member
Maybe this is intended, but if it is it needs documentation and explanation!

Game version: v1.93-beta.6-(06d4cce) (2019-11-14 00:00)
HTML5 Yes/No: yes
Game world: beta
Browser/IOS/Android + version: firefox 70.0.1 (64 bits)
Flash Player version: NA
Operating System or Mobile Device: windows 10
Screen resolution: 1940x1080
Account name: maxiqbert
Humans or Elves: elves

Reproducibility:
5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)

Quest title: (if applicable)

Current situation:
__ when I try to get a teleported item back from the inventory, it's not working if all my builders are already at work
__

Expected situation:
one of the above would be right
_ every item from your inventory is used the same way, meaning you take from the inventory and place it down, without builder
_ the need for the builder is intended, then you can not take it out from the inventory unless you have a free builder

Reproduction Steps
1. teleport a residence (or anything "buildable", not from an event)
2. put your builders at work
3. open your inventory
4. take your residence (or whatever from 1)
5. see you cannot place it anywhere


Add more steps if needed. Include only ONE action for each step!

Screenshots of the bug:
 

Theodore

QA Moderator
Elvenar Team
If placing a building that was teleported back to inventory, it may require a builder. If the building required a builder initially, it will do so when placed back in the city. For instance, a magical residence can be placed back in the city without a builder. A regular residence, on the other hand, when placed back in the city does require a builder.

This is not a bug. It works the way it was intended.
 

-Akaloo-

Guest
Hi,
I used a teleport building enchantement to teleport a Worshop (it was crafting) and the teleport was right but when I tryed to reinstal it I couldn't do it without understing why ..
So I came to the forum to look why.. and understood that my builders wasn't free..

:cool: Maybe it could be great to have the same message that we could have usually when builders aren't free ? ;)
 

maxiqbert

Well-Known Member
If placing a building that was teleported back to inventory, it may require a builder. If the building required a builder initially, it will do so when placed back in the city. For instance, a magical residence can be placed back in the city without a builder. A regular residence, on the other hand, when placed back in the city does require a builder.

This is not a bug. It works the way it was intended.
ok, it's not a bug
it's still not consistent, because for other requirements, you can't pick the building from the inventory, and the missing element is red
 

Theodore

QA Moderator
Elvenar Team
it's still not consistent, because for other requirements, you can't pick the building from the inventory, and the missing element is red
I won't argue with you on that. IMO, it should show the builder count red. I will ask Marindor to forward as suggested improvement. Thank you for your input.