1. Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!
    Dismiss Notice

Not a Bug Single " turns into ' in chat/mail

Discussion in 'Archive: Bugs and Errors' started by Jasper, Sep 9, 2018.

  1. Jasper

    Jasper Well-Known Member

    Joined:
    Jan 29, 2015
    This is probably related to how they tried to fix https://beta.forum.elvenar.com/index.php?threads/22867-turns-in-to-in-chat.11171/

    US-International keyboard layout settings
    If you type a single " (+ space to see the " appear) it turns into a ', however is you type 2x " it show up correctly as "". :confused:
    Happens in both chat and mail.

    Game version: v1.63-(f10b4e74c)-(master) (2018-09-04 15:10)
    HTML5: No
    Game world: zz1
    Browser + version: Firefox 62.0 (64-bit)
    Flash Player version: 30.0.0.154
    Operating System: W7 x64 Enterprise
    Screen resolution: 1920x1200
    Account name: Lord Soth
    Humans or Elves:
    Elves
     
    Last edited: Sep 9, 2018
  2. Nightspark

    Nightspark
    QA Moderator
    Elvenar Team

    Joined:
    Mar 20, 2017
    I can't recreate that. I tried English (UK) and English (US) keyboard setting, I don't have an US-International setting. What key is the " on your keyboard?
     
  3. Jasper

    Jasper Well-Known Member

    Joined:
    Jan 29, 2015
    English (UK) and English (US) are probably the language settings, not keyboard layout settings. You probably need to add US-International keyboard layout first.

    I've have a Razer Blackwidow Chroma, " is next the ENTER, you have to use Shitft + ' to get it.

    upload_2018-9-9_22-49-45.png
     
  4. Nightspark

    Nightspark
    QA Moderator
    Elvenar Team

    Joined:
    Mar 20, 2017
    Okay, finally managed to find the same keyboard and tested this. My attempt to type " is also broken but not just in the game but also on forum and other text boxes (like chat program). When I hold shift and hit the " key I don't get any character until I also hit an other key (space bar or anything else). However because it's also present in all my other programs I think it's an issue with the keyboard layout, not the game itself, but will check with the guys.

    After checking with the seniors, it will be marked as not a bug.
     
    Last edited: Sep 12, 2018
  5. Jasper

    Jasper Well-Known Member

    Joined:
    Jan 29, 2015
    That the way it is suppose to work with US-international but that's not the problem I tried to describe. o_O
    The problem is that if you hit shift + " (+ another key) in chat it only give a ' (single quote) and not a double quote. Try the same thing her on the forum (or in Notepad) and you will get a " (double quote) like you would expect.

    I just found out that if I keep holding down the Shift key in chat after I type " and hit another key I do get a " but if I release the Shift key after " and then hit another key it turns into ' :eek:

    I get the impression that keyboard handling in chat is a bit slow and is missing key strokes sometimes resulting in this effect.
     
  6. Nightspark

    Nightspark
    QA Moderator
    Elvenar Team

    Joined:
    Mar 20, 2017
    Either way, I can't repro the ' mark and that keyboard is acting weird outside of the game too for me. You could try to switch keyboard layout?
     

Top