• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Discussion Release Notes 1.171

Deadeye Jerry

Community Manager
Elvenar Team
Dear Humans and Elves,

Please see the Release Notes of our current game version here and let us hear your thoughts about it in this thread!

Kind regards,
Your Elvenar Beta Team

Amy Steele

Forum/QA Moderator
Elvenar Team
Indeed the event is already finished here on beta, but it is still ongoing on live. The fact that this issue was caught and fixed on beta means it will not affect players on live. This, after all is the purpose of beta.

The more bugs we can find, and the quicker we find them, the more chance our development team have of fixing them before live release, and the better the game experience on live becomes


Well-Known Member
Hello Team,
we have got a new update from 1.171:

V1.171-beta-(f0bb03b) – html5 (2023-03-06 13:46)

Now I can't deposit Ancient Knowledge into my Ancient Wonders.

I can`t use time booster.

I restarted the game - the error persists.

Can you please forward this bug?


Well-Known Member
After the update today:

- Time booster doesn`t work
- Ancient Wonder doesn`t work
- Spire is not working right -------------------------------> works right by me
- and /who doesn`t working again

Dorfl the Clay

Well-Known Member
After the update today:

- Time booster still doesn`t work
- Ancient Wonder still doesn`t work
- Spire graphics in progres tree back to 'normal', contents chests still invisible
- /who works (always did)

Can't avoid the assumption INNO recently (last 6 months?) hired new software engineers who keep making a mess of things. And if a change/update causes a bug, it might be a better system to a. first reverse the change. b. then start to search where you screwed up...

Dorfl the Clay

Well-Known Member
After the last fix to date:

- Time boosters available
- Ancient Wonders available
- content of the chests in the Spire still invisible

It's a slow proces.. but we're getting there! :cool:


Well-Known Member
this is also not fixed