• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [6215] Grafic bug in town

Denali

Guest
Have a look to this nice things:
vvv.JPG


It happens after visiting all possible guild members and than I visited my neighbors with the maximum possible clicking speed.
The bug with the funny plank manufacture is static.
The other bugs are dancing around. Sometime there is a second building and sometimes not. It switches I think every 0.5 seconds. You see there two buildings in the same slot.

Edith says:
It happens when I visit small towns. In bigger towns the bug is not there.
Pandorah --Yes
cormyr --Yes
Fllow -- No

Only small human workshops have the double problem.
on bedals town:
jumping1
jump 1.JPG


jumping 2
jump2.JPG

If I switch between the towns, I can reproduce it. The red workshop is static.


Actual needed RAM

ffff.JPG


Player Name:
Denali

World: beta

Operating System: win8.1

Browser and Version:waterfox

Screen Resolution: 1920 x 1080
 
Last edited by a moderator:

Muf-Muf

Elvenar Team
Interesting. We are able to confirm it happening, we just don't know exactly why it happens (which is quite important to get it fixed). Does anyone know some sort of way that this behaviour can be reproduced with? Any information could be useful. :)
 

Elderflower

Well-Known Member
I agree with Denali that it only happens with my smallest fellowship member who has 290 points and ranks 10363. Today it is only their marble manufactory that is cycling although their workshops are still squared off and look too advanced for their level.
The next two smallest players, at 1524 points, rank 9427; and 1642 points and rank 9369 respectively only show oddly shaped manufactories but they do not cycle through various phases.
I hope this helps
 

Attachments

Golem1

Guest
Yes, last nite seen characters dancing around. I thought I had too much wine, so I just let it go.
 

Anne65

Well-Known Member
I have posted this problem on the dutch forum. I didn't notice the problem here, because there weren't new small cities around me. On the dutch server, I got a lot of new neighbours lately. I am an elf there, same as here. So it happens to human and elven cities.
It seems it only happens when the hardware acceleration is ON. When I turned it off, I didn't see it anymore.
When I empty the cache and/or reload the game, the cities that first had the bug, don't have it anymore when I visit them immediatedly, but after visiting a few, the bug is back.
Elves only see this bug when visiting small elven cities and humans only see it when they visit small human cities. And that is because you see a part of your own city in the small city. I upgraded my workshops from level 9 to 11, so I can see what happened. I see a part of my own workshop, my own barracks, my own planks factory and such in the small city that I am visiting. I made screenshots last week and now the same cities with the bug have the upgraded workshop of me in it.

I never drink, so I wasn't drunk, but the first time I emptied my cache memory after a request from a moderator, I thought I wasn't drunk so I should be crazy. I had made screenshots before and after reloading, the workers were suddenly moving, where I first saw 1 workshop, there were suddenly 3, the barracks of the city I visited were switching to a part of my own barracks and such. Really weird.
Anyway, I hope the additional information in bold helps a bit.

How to reproduce it:
Turn ON the hardware accelaration.
Visit some cities and then visit small cities of your own kind. You will see the bug. Maybe not in the first small city, but after visiting a few, it should be visible.
Visit some small cities of the other kind, you shouldn't see a bug. So no bug in human cities when you're an elf, or no bug in elven cities when you're a human.
Turn OFF the hardware accelaration, visit the same cities again. The bug should be gone, at least I didn't see it anymore.
Turn ON the hardware accelaration and visit the same cities again. The first cities might not have the bug, but when you keep visiting them, the bug will return and it might look different from the first time you saw it.
Close the game, empty your cache, open the game again and visit the same cities again, with the hardware accelaration on. The bug will come back after some cities. So emptying the cache isn't the solution.

Edit: the bug on the dutch server started after the upgrade for the hardware acceleration, didn't have it before.
 
Last edited:

Elderflower

Well-Known Member
You are absolutely spot on. I just tested it with the hardware acceleration on and off and it was just as you say. I don't know if it is a reflection of my city. What puzzles me is that in some cities it is the manufactories that are changed as well as the workshops. Also in at least one city there is a steel manufactory that is shows an advanced but stable image whereas the marble manufactory cylces through several stages. They are both at level one in actual fact.

I wonder if the reason it happens in small cities is that they are more likely to have level one production buildings
 
Last edited:

Anne65

Well-Known Member
It reflects my workshops, tier 1 manufactories (planks in dutch server) and sometimes also the barracks (screenshot 17aug). I am saying it reflects MY buildings, because of the change in workshops between last week and today. I visit all my neighbours every day so I can buy goods with the coins. That's why I am pretty sure about this. I have seen the bug of the same workshops for days (it showed a level 9 or 10 workshop, the level of my workshop there) and today the bug was suddenly changed to a workshop of level 11. Guess what I did last night? I upgraded the workshop from 10 to 11. And now the bug looks different, while it has been the same for days. Still the workhop, still the same place, but a different level. Most bugged cities show 1 or more workshops, just 1 or 2 cities show 2 plank manufactories level 15 (which I have there) and another city showss a part of my barrack. When I visit that city, it shows their barrack, but then it switches to a part of mine and then back. Look at the screenshots and you will see what I mean. One of the screenshots is from a few days ago (my workshops at level 9 or 10, screenshot bug4) the other is from today (my workshop level 11, screenshot 17aug2) Screenshots are made on the dutch server.

I don't see a (reflection) of my tier 2 and 3 manufactories. I also don't see a reflection of marble or steel manufactories (because I only have planks in the dutch city).

I guess this can be tested. If I know a small elven city on the beta server, I can visit it and make screenshots. I have workshops level 15 and steel manufactories here. I should see steel. If someone else with planks or marble visits that same city, he should not see steel, but planks or marble. That means the ame city should show a different bug to people, depending on their own manufactories.
 

Attachments

Elderflower

Well-Known Member
Not the wine. no ;)
I just reproduced it in my own city. I built a level 1 workshop and sure enough, with the hardware acceleration on it has a workshop next to it that cycles through levels 13,14 and 15 which are my other level workshops. If I turn the acceleration off all is quiet.
my new workshop.jpg


I haven't tried a manufactory yet as I don't have enough spare population but I'm sure it would be the same.
 

Anne65

Well-Known Member
Well, maybe that helps. I just visited your town. No bug at first, then visited 2 other cities and your town again. And I see something else.
Elderflower.png


My workshops are at level 15.
Now if I am right, you (elderflower) don't have a steel manufactory at level 15. So maybe can you remove that level 1 workshop and build a level 1 steel manufactory there? And see what we get then? My steel is at level 15, that's why I ask.
I will try the same on the dutch server, need to wait there for my builders.
 

Elderflower

Well-Known Member
Done. And you were spot on. For me it shows my highest level steel which is 12. It even showed that while it was being built:rolleyes:
new steel factory - in progress.jpg

It is static and maybe that is because I do not have any other steel above 12
 

Anne65

Well-Known Member
Look at this.
Elderflowersteel.png


I see a lower level steel in your screenshot and a level 15 steel in my screenshot of your town. Maybe now just wait for some comment on this. This might be enough information for the developers.

We made this a "find the differences between 2 pictures" game. :)

Edit:
I was able to reproduce this in my own town on the dutch server too. I made a new planks manufactory. And indeed, it is static. It isn't static when I visit your town. It is static in my own. The new manufactory looks normal but it created a manufactory level 15 which is static too on the road to the residences which shouldn't be there. Creating a marble building doesn't show a bug at all ( I don't have any other marble building).

New planks.png

I suppose it has to do with the buildings near the main hall, not sure about that though.

Reproduce:
1. Make some space near your main hall so you can build something there.
2. Place a level 1 workshop there.
3. Look at the bug, if you don't see any, visit a few other cities first.
4. Remove the workshop level 1 and build a manufactory. This manufactory has to be the same as a high level manufactory in your city. So if you don't have marble, then don't build marble. If you don't have planks, then don't build planks.
5. Look if you see a bug. If you don't, visit some other cities first and then go back to your own again.
 
Last edited:

Elderflower

Well-Known Member
That's really neat. If they can reproduce it I'm sure they can fix it. Have a great day.

Oh dear. Maybe they are trying to fix this because I am suffering from Vanishing City Syndrome again. Right now the only building I can see in my city is a residence I just upgraded. Perhaps the two situations are related. I don't think my baby production buildings are very close to my town hall.
 
Last edited:

Golem1

Guest
Since the elves are dancing, can we presume that THEY drink wine too???