• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [33624] Military production buildings are bugged

Dony

King of Bugs
Game version: v1.114-beta.10-(c3dc6ad) (2020-09-23 09:01)
Game world: zz1
Browser + version: Firefox 80.0.1 64-bit
Flash Player version: 32.0.0.433
Operating System: Windows 10
Screen resolution: 1920x1080
Account name: Dony
Humans or Elves: Elf

Reproducibility: 5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)

Quest title: none

Current situation:

If the productions from Barracks, Mercenary Camps, Training Grounds are finished while being offline, then when you log in training timer is reset to 0 and you start again

Expected:
Production timers should never be affected in any possible way.

Reproduction steps:
1. Open Barracks
2. fill all 5 queue slots
3. use boosters or wait before first training slot is about to be finished
4. before it finishes, log out
5. wait half hour for example
6. log back in
7. mouse over Barracks
8. observe that production for next slot just started, instead of 30 minutes ago

all 3 buildings are affected
 

PaNonymeB

Well-Known Member
It also affects MA, and someone on live forum reported it also affects Senate. It also seems that you don't actually lose production. For example, I had something like the reproduction steps below happen in my live city :
  1. Have L5 MA
  2. At 00:00 start production of 5 catalysts, log out
  3. At 10:00 log in and collect 1 catalyst. The second one is showing 6h left (just starting).
  4. Log out, and log back in at 14:00. No catalyst ready and 2h left for the next one. (While we should be at 4h left for the 3rd catalyst.)
  5. Use a 5h time instant or wait 5 hours
  6. See two catalysts are ready and the following one is at 5 hours left (or just starting production if you just logged in after waiting 5 hours). So finally you effectively got 3 catalysts after 19 hours.
 
Last edited:

Dony

King of Bugs
The above problem was reported on the forum pl.
https://pl.forum.elvenar.com/index.php?threads/b%C5%82%C4%85d-przy-produkcji-wojska.5004/ A week has passed since your application.
i dont care about problems on your live server tho
The only way to get around this error.
When you return to the game and see that the slot is being reset, cancel it and the next slot will recover the lost time.
actually it works as @PaNonymeB said, server using correct timings and game has only visualisation problem, production will catch up regardless of your action in game
 

chris0707070707

Active Member
i dont care about problems on your live server tho
The point is, the problem has been already reported, reproduced and confirmed on live server a week ago, which means IG is working on it.
That makes reporting that bug on beta and any further discussion superfluous.
server using correct timings and game has only visualisation problem, production will catch up regardless of your action in game
No, it's not just a visualisation problem. I don't want to go into detail, but we've been testing it for a week and there are situations (depending on play style), where this bug leads to lower overall production.
 

PaNonymeB

Well-Known Member
No, it's not just a visualisation problem. I don't want to go into detail, but we've been testing it for a week and there are situations (depending on play style), where this bug leads to lower overall production.
Could you detail the reproduction steps to get to this situation ?
 

Eilin

Member
Steps:

1. You start production in all slots in your Barracks/Mercenary Camp/Training Grounds/Magic Academy...
2. You leave the game
3. The first slot ends production (you are not in the game!!!)
4. The second slot starts production
5. The second slot should be for egsample half done
6. You log in to the game
7. The second slot reset the time and start production from the beginning
8. You lost the time of the production...
BUT
9. You can cancel the buged slot
10. The next slot will then show the lost time

Important to see the bug!
You cannot be logged in to the game while the first slot finishes production and the second starts!
You have to wait at least a few minutes before you log in, to see that the time has been reset!

Here you can see what it looks like on the screenshots
 
Last edited:

chris0707070707

Active Member
Could you detail the reproduction steps to get to this situation ?
Sure. Just two quick examples.

Example 1: Training using brown bears. In this case one has to wait until all 5 slots are done.

1. Start training in 5 slots x 4 hours each = 20h total training time (it's just an example)
2. If you login into tha game after 19h (it doesn't matter what you did until then) the last slot (currently in production) resets it's progress to zero and you have to wait full 4 hours in order it to finish. You lose 3h untill all 5 slots are done. Total training time of 5 slots is 23 hours instead of 20 hours. You don't get those 3 hours back since it was the last slot. You don't have any more slots you could cancel manually in order to get the time back in the next slot.

Example 2: short training queue

1. Start training in 5 slots x 1 hour each at, let's say, 17:00 pm. Total training time = 5 hours. You schedule your last login at 22:00, you plan to collect the production from all 5 slots, to start the training cycle again and to go to sleep.
2. Lets assume you login into the game shortly before 22:00 pm. Your last slot's training progress resets to zero, meaning you can't collect the whole production at 22:00 as scheduled. You can start new production in 4 slots instead of 5.
3. You collect your trained troops the next morning. The result is, you have trained 9 slots in total instead of 10.

Sure, there are workarounds and ways to reduce the bugs' impact (like adjusting the training size, login times and so on), but since you need to actively do something in order it to work, no one can speak of "just a visualisation problem".
 

Elvercikk

Member
It seems, that the bug with unit production has been fixed. In my buildings it works correct :) In the academy, he also shows the correct time :)
@Marindor There is a chance to fix this bug on live servers today?