• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [31685] spire : cannot fight (all Barracks units unavailable)

maxiqbert

Well-Known Member
Game version: v1.104-beta.11-(2f3a787) (2020-05-04 15:26)
HTML5 Yes/No: yes
Game world: beta
Browser/IOS/Android + version: firefox 75.0 (64 bits)
Flash Player version: NA
Operating System or Mobile Device: windows 10
Screen resolution: 1920x1080
Account name: maxiqbert
Humans or Elves: elves

Reproducibility:
5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)

Quest title: (if applicable)

Current situation:
__ when in the spire, if you choose different kind of troops, you don' t enter the fight, you get a message error (see screenshot)
__ after you close the error window, you cannot go back to the fight, you must first leave the spire

Expected situation:
__ the fight should be resolved
__

Reproduction Steps
1. enter the spire
2. select fight
3. select various troops (it doesn't happen always if you select only one kind of troops)
4. click autofight
5. get the message


Add more steps if needed. Include only ONE action for each step!

Screenshots of the bug:
cannot battle.jpg
 

Konys

QA Moderator
Elvenar Team
Confirmed; Barrack's units are missing so we cannot fight neither in Spire nor in World Map.
 

Dony

King of Bugs
I dont have barracks units, but can fight both in spire and world map with units from MC or TG, in flash and in HTML5
 

Muf-Muf

Elvenar Team
It appears that all Elven players have had their units turned into Human troops, and all Human players now have the Elven troops from the Barracks. Because the Human troops are not available for Elven players (and vice versa), you cannot currently use them in battles, resulting in error messages like the one shown above.

Please bear with us while we investigate how this happened and work on a solution. Our apologies for the inconvenience.
 

Dony

King of Bugs
If we train new units in barracks, will it be added once this bug is fixed or removed and replaced with transformed units?
 

Muf-Muf

Elvenar Team
That is a good question. I've raised the same concern with our dev team some minutes ago, but I'm afraid there is no definitive answer to that question yet. :)
 

Karvest

Well-Known Member
Hope they would add up bad race units to current state of barracks.
Since it doesn't even require server restart.
 

Muf-Muf

Elvenar Team
We must ensure that whatever we do does not introduce further issues, which will require some time. Both to test the solutions, and to catch as many edge cases as possible and make sure that those are handled properly too. :)
 

Muf-Muf

Elvenar Team
Hahaha, we're doing what we can. Our developers are still looking into it now. If we can fix it today, we will. But we cannot promise that we can at this moment, though. We're doing what we can, but we also have to avoid risks (we don't want to break more, and especially not at this time of day - it's 8pm here in Germany now). :)
 

Richord

Well-Known Member
not true. When everybody had troubles, I didn't.
want to go to bed, start productions; units gone...
 

Richord

Well-Known Member
well, I offered literally over a dozen options to get it fixed for a member of mine and nothing worked. So I didn't even try. It just worked the morning after.