• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Fixed [27972] The 'Origin of prejudice' quest always on 11/12

Veeb

Well-Known Member
Game version: v1.85-(48bd10a)-(master-stable) (2019-07-19 08:59)
HTML5 No: (but also on mobile)
Game world: Beta
Browser/IOS/Android + version: Version 75.0.3770.142 (Official Build) (64-bit)- (Mobile Android also)
Flash Player version: 32.0.0.223
Operating System: Win 10
Screen resolution:
Account name: Veeb
Humans or Elves: Elves
Reproducibility: 5/5 (1/5 = happened once; 2/5 = happens randomly; 3/5 = happens sometimes; 4/5 = happens often, but not always; 5/5 = happens always)
Quest title: The Origin of Prejudice. Have 12 Production Islands on level 4.
Current situation: Well the quest has always stated 11/12. So I thought wow, my lucks in, an awesome bug and fast tracked a lv 3 building to level four with a 14hr and 8 hr time pack BUT NOOOOOOOO it stayed at 11/12 and even after all 12 islands were level 4 it still says 11/12. Incidentally I did have to level up one of the islands twice for a previous level as it didn't register, although I wasn't 100% sure at the time so just did it again which then worked.
__
__
Expected situation: It should have started at 8/12 and then increased by 1 every time I levelled up a production island to level 4 till it registered to 12/12. I should be on the next quest but I'm stuck in limbo waiting for support to fix it.
__
__
Reproduction Steps
1. Play game see it says 11/12
2. Upgrade an island see it still says 11/12
3.Upgrade island 3 more islands still says 11/12
4. Notice that should have worked as has 12 islands level 4 then contact support
5. support try to fix quest and now it try but still fails to complete.
Add more steps if needed. Include only ONE action for each step!
Screenshots of the bug:
(add as many screenshots as you need)
This is the 11/12 image that has been the same since it should have said 8/12.
11 out of 12 bug.PNG


So after I contacted Support as I thought it was already a bug they tried to fix it which seemed to work see below image but as soon as you click on the ok it reverts to previous 11/12 image. You can refresh and repeat over and over. lol

As they said its a new bug so I have to be patient (Argh) I decided I might as well get some diamonds for it too.

half fixed lol.PNG