• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Search results

  1. Aider

    Foaly

    Welcome to the team! Watch out for Marindor, I've heard he's a ruthless creature. ;)
  2. Aider

    Fixed [10001] Can gather coins from gold mines with full coin storage

    I had this happen as well. :)
  3. Aider

    Duplicate Sorceresses called Príests

    Hi Brummbaer - Seems this issue is the one linked below for you. ;) https://beta.forum.elvenar.com/index.php?threads/8842-sorceresses-called-priests.4447/
  4. Aider

    Not a Bug Cannot produce Power of Provision spell

    Hello sterion - Do you have the required relics to produce the spell (are any of them red)?
  5. Aider

    Not a Bug Magic Academy Quest not declinable

    Hi Grace - Good to see you around again. ;) I am pretty sure this is intentional as the Magic Academy cannot be deleted and is a required building for progression on the tech tree. :)
  6. Aider

    Fixed [8842] Sorceresses called priests

    Oh noes! Getting same issue as OP. :)
  7. Aider

    [Discussion] Release Notes version 1.1 + Chapter VII: Fairies

    Umm, I'm pretty sure all it has to do is be confirmed by a moderator and not a "known" bug. If you aren't credited your Diamonds, you are always welcome to submit a ticket as the moderation team has stated in previous posts. :) But...to each his own. ;)
  8. Aider

    Not a Bug Research tree arrows are misplaced

    Woohoo! Looks like Grace and I were able to find out the cause for this one. :) Edge auto zoom'd to 200% on her browser due to her screen res. Once it goes to 200% or above the line will become misaligned. Once decreasing the browser tab zoom by one it will fix itself. :) Good work Grace! ;)...
  9. Aider

    Duplicate "Return home" doesn't work

    I can confirm this. :)
  10. Aider

    Fixed [8803] Quest completion not recognized

    I can confirm this. :)
  11. Aider

    Duplicate Trading rating system

    Duplicate to https://beta.forum.elvenar.com/index.php?threads/4-star-trade-rating.4382/
  12. Aider

    Cannot reproduce Map neighbor titles missing box

    Hi Bobbykitty - This looks like a loading error to me. Have you tried closing some of your tabs and refresh to see if the error still occurs? I'm not getting any problems on my end. :)
  13. Aider

    Fixed [8805] Nightshade production time in Night Farm

    Hi Celeborn - I was not able to reproduce your error. Can you try editing your original post using the bug format found here to help those looking into the issue.
  14. Aider

    Not a Bug Research tree arrows are misplaced

    Hi Grace - I was not able to reproduce this issue. Have you tried refreshing your browser and clearing your cache? When trying a different browser do you encounter the same issue?
  15. Aider

    [Discussion] Coming soon!

    I agree! :) Prettier than those nasty dwarves. :X
  16. Aider

    Cannot reproduce Trader Visual misaligned

    Hmm. I wasn't able to reproduce this. My trader icons were aligned on all three tabs. Have you tried refreshing your browser as well as clearing your cache after the recent update?
  17. Aider

    Not a Bug [10322] Inventory alert total is incorrect

    I wasn't able to reproduce this. I que'd two spells and added them, my bag showed two and my spell tab showed two as well.
  18. Aider

    Fixed [8556] Costs of upgrade to level 3 for magic academy not showing

    I agree with Anne65 - I do not believe that is the intended logic behind the upgrade. :)
  19. Aider

    Fixed [8575] After winning battle: wrong province + extreme negotiation costs

    Was able to confirm - maybe take out new encounter on step four and replace with new province. It takes you to a whole new (far away) province. Also, this only appears when fighting manually. Auto-fight produces the correct result. :)