• Dear forum reader,

    To actively participate on the forum by joining discussions or starting your own threads or topics, you need a game account and to REGISTER HERE!

Search results

  1. ULISE

    Fixed Battle

    My english is no good but, the battle still no work!!!!
  2. ULISE

    Fixed Battle

    I can use my units in any battle in manual mode!
  3. ULISE

    Duplicate Cannot use Ancient Knowledge Instants to fill wonders

    This game is fast approaching its end!!!!
  4. ULISE

    1 sponsored membership available in 10 chest fellowship

    Hello! I am ULISE from Romania and I play Elvenar since 2015. I want to join on your Guild. Thanks!
  5. ULISE

    Active Fellowship for Tournament

    Hello! They are "ULISE" from Romania. I've been playing "Elvenar" since the beginning, that is, since 2015 and I'm looking for an alliance. I am an active player who has the following "philosophy" of the game: 1. Tournament with a minimum of 10 chests each week; 2. The adventure with the first...
  6. ULISE

    Discussion Release Notes version 1.94

    Still no KP visible!!!!!!
  7. ULISE

    Fixed [28958] Cannot collect treant from the pyramid

    I can not cllect any troops from Wanders!
  8. ULISE

    Discussion Spire of Eternity

    I am playing "Elvenar" starting in 2015 and I think I have a lot of experience, especially in the provinces or tournaments. These battles take them manually. I have never lost a fight in manual mode no matter how difficult it is. Regarding the fights in May 3 Waves from Spire of Eternity, I have...
  9. ULISE

    Discussion Spire of Eternity

    When can we use manual combat?
  10. ULISE

    Answered Event Summer Solstice

    Where can I find Vision Vapor? Thanks!
  11. ULISE


    I am ULISE! My wonders Prosperity Towers on final: 188/220 - runes and PK
  12. ULISE

    Duplicate Buildings and Research

    1. Disappearing buildings in my city and they can not use it. Reset my browser and another building disappearing!!!!!!!!!!!!!! 2. I research City expansion 11, but I can not place it What happens?